2011/10/12(Wed)壊れたyumの修復

2011/10/12 15:35 Software::Linux
Fedoraに搭載されているパッケージ管理システムyumは、とっても優れたコマンド体系だと思っているが、ちょっとトラブったのでメモ。

状況

遠隔サーバにsshしてsudo yum updateしていたのだが、回線トラブルで更新中に切断されてしまった。なんてこったい!
// screen上で動かしてれば……と後から悔やんでも仕方ない。

yum updateするとこんな感じ。
$ sudo yum update
読み込んだプラグイン:presto, refresh-packagekit
更新処理の設定をしています
依存性の解決をしています
--> トランザクションの確認を実行しています。
---> Package exiv2-libs.i686 0:0.21.1-1.fc15 will be 更新
---> Package exiv2-libs.i686 0:0.21.1-3.fc15 will be an update
---> Package fftw.i686 0:3.2.2-5.fc15 will be 不要
---> Package fftw-libs.i686 0:3.3-2.fc15 will be obsoleting
---> Package fuse-libs.i686 0:2.8.5-5.fc15 will be 更新
---> Package fuse-libs.i686 0:2.8.6-1.fc15 will be an update
---> Package gnome-python2-gtkhtml2.i686 0:2.25.3-34.fc15 will be 更新
---> Package gnome-python2-gtkhtml2.i686 0:2.25.3-35.fc15.1 will be an update
---> Package gnome-python2-libegg.i686 0:2.25.3-34.fc15 will be 更新
---> Package gnome-python2-libegg.i686 0:2.25.3-35.fc15.1 will be an update
---> Package gnome-screensaver.i686 0:3.0.0-1.fc15 will be 更新
---> Package gnome-screensaver.i686 0:3.0.1-1.fc15 will be an update
---> Package iw.i686 0:0.9.22-1.fc15 will be 更新
---> Package iw.i686 0:3.1-1.fc15 will be an update
---> Package libburn.i686 0:1.1.0-1.fc15 will be 更新
---> Package libburn.i686 0:1.1.4-1.fc15 will be an update
---> Package libdhash.i686 0:0.4.2-4.fc15 will be 更新
---> Package libdhash.i686 0:0.4.3-5.fc15 will be an update
---> Package libgcj.i686 0:4.6.0-10.fc15 will be 更新
---> Package libgcj.i686 0:4.6.1-9.fc15 will be an update
---> Package libisofs.i686 0:1.1.2-1.fc15 will be 更新
---> Package libisofs.i686 0:1.1.4-1.fc15 will be an update
---> Package libtool-ltdl.i686 0:2.4-4.fc15 will be 更新
---> Package libtool-ltdl.i686 0:2.4-6.fc15 will be an update
---> Package lzo.i686 0:2.03-4.fc15 will be 更新
---> Package lzo.i686 0:2.06-1.fc15 will be an update
---> Package nfs-utils.i686 1:1.2.4-2.fc15 will be 更新
---> Package nfs-utils.i686 1:1.2.4-3.fc15 will be an update
---> Package pcsc-lite.i686 0:1.7.2-3.fc15 will be 更新
---> Package pcsc-lite.i686 0:1.7.2-4.fc15 will be an update
---> Package perf.i686 0:2.6.40.4-5.fc15 will be 更新
---> Package perf.i686 0:2.6.40.6-0.fc15 will be an update
---> Package postgresql-libs.i686 0:9.0.4-5.fc15 will be 更新
---> Package postgresql-libs.i686 0:9.0.5-1.fc15 will be an update
---> Package protobuf.i686 0:2.3.0-7.fc15 will be 更新
---> Package protobuf.i686 0:2.3.0-8.fc15 will be an update
---> Package qt-x11.i686 1:4.7.3-8.fc15 will be 更新
---> Package qt-x11.i686 1:4.7.4-2.fc15 will be an update
---> Package rdesktop.i686 0:1.6.0-12.fc15 will be 更新
---> Package rdesktop.i686 0:1.7.0-1.fc15 will be an update
---> Package sane-backends.i686 0:1.0.22-3.fc15 will be 不要
--> 依存性の処理をしています: sane-backends = 1.0.22-3.fc15 のパッケージ: sane-backends-libs-1.0.22-3.fc15.i686
---> Package sane-backends-drivers-scanners.i686 0:1.0.22-4.fc15 will be obsoleting
---> Package tar.i686 2:1.26-1.fc15 will be 更新
---> Package tar.i686 2:1.26-2.fc15 will be an update
---> Package tigervnc.i686 0:1.0.90-4.fc15 will be 更新
---> Package tigervnc.i686 0:1.1.0-1.fc15 will be an update
---> Package usbutils.i686 0:003-2.fc15 will be 更新
---> Package usbutils.i686 0:003-4.fc15 will be an update
---> Package vim-minimal.i686 2:7.3.289-1.fc15 will be 更新
---> Package vim-minimal.i686 2:7.3.315-1.fc15 will be an update
---> Package vpnc.i686 0:0.5.3-12.svn457.fc15 will be 更新
---> Package vpnc.i686 0:0.5.3-13.svn457.fc15 will be an update
---> Package xscreensaver-extras.i686 1:5.14-1.fc15 will be 更新
---> Package xscreensaver-extras.i686 1:5.15-1.fc15 will be an update
---> Package xscreensaver-gl-extras.i686 1:5.14-1.fc15 will be 更新
---> Package xscreensaver-gl-extras.i686 1:5.15-1.fc15 will be an update
--> 依存性解決を終了しました。
エラー: パッケージ: sane-backends-libs-1.0.22-3.fc15.i686 (@anaconda-InstallationRepo-201105131946.i686)
             要求: sane-backends = 1.0.22-3.fc15
            削除: sane-backends-1.0.22-3.fc15.i686 (@anaconda-InstallationRepo-201105131946.i686)
                sane-backends = 1.0.22-3.fc15
            次のものにより不要にされた: : sane-backends-drivers-scanners-1.0.22-4.fc15.i686 (updates)
                見つかりません
            インストール: sane-backends-1.0.22-4.fc15.i686 (installed)
                sane-backends = 1.0.22-4.fc15
            利用可能: sane-backends-1.0.22-1.fc15.i686 (fedora)
                sane-backends = 1.0.22-1.fc15
 問題を回避するために --skip-broken を用いることができません
** Found 80 pre-existing rpmdb problem(s), 'yum check' output follows:
1:NetworkManager-0.9.1.90-3.git20110927.fc15.i686 は 1:NetworkManager-0.9.0-1.fc15.i686 の複製です
1:NetworkManager-glib-0.9.1.90-3.git20110927.fc15.i686 は 1:NetworkManager-glib-0.9.0-1.fc15.i686 の複製です
abrt-2.0.3-4.fc15.i686 は abrt-2.0.3-1.fc15.i686 の複製です
abrt-addon-ccpp-2.0.3-4.fc15.i686 は abrt-addon-ccpp-2.0.3-1.fc15.i686 の複製です
abrt-addon-kerneloops-2.0.3-4.fc15.i686 は abrt-addon-kerneloops-2.0.3-1.fc15.i686 の複製です
abrt-addon-python-2.0.3-4.fc15.i686 は abrt-addon-python-2.0.3-1.fc15.i686 の複製です
abrt-desktop-2.0.3-4.fc15.i686 は abrt-desktop-2.0.3-1.fc15.i686 の複製です
abrt-gui-2.0.3-4.fc15.i686 は abrt-gui-2.0.3-1.fc15.i686 の複製です
abrt-libs-2.0.3-4.fc15.i686 は abrt-libs-2.0.3-1.fc15.i686 の複製です
abrt-plugin-bugzilla-2.0.3-4.fc15.i686 は abrt-plugin-bugzilla-2.0.3-1.fc15.i686 の複製です
abrt-plugin-logger-2.0.3-4.fc15.i686 は abrt-plugin-logger-2.0.3-1.fc15.i686 の複製です
1:cheese-3.0.2-2.fc15.i686 は 1:cheese-3.0.1-2.fc15.i686 の複製です
1:cheese-libs-3.0.2-2.fc15.i686 は 1:cheese-libs-3.0.1-2.fc15.i686 の複製です
cpp-4.6.1-9.fc15.i686 は cpp-4.6.0-10.fc15.i686 の複製です
1:cups-1.4.8-5.fc15.i686 は 1:cups-1.4.8-2.fc15.i686 の複製です
1:cups-libs-1.4.8-5.fc15.i686 は 1:cups-libs-1.4.8-2.fc15.i686 の複製です
curl-7.21.3-12.fc15.i686 は curl-7.21.3-11.fc15.i686 の複製です
firefox-7.0.1-1.fc15.i686 は firefox-6.0.2-1.fc15.i686 の複製です
fuse-2.8.6-1.fc15.i686 は fuse-2.8.5-5.fc15.i686 の複製です
gcc-4.6.1-9.fc15.i686 は gcc-4.6.0-10.fc15.i686 の複製です
gcc-c++-4.6.1-9.fc15.i686 は gcc-c++-4.6.0-10.fc15.i686 の複製です
gcc-gfortran-4.6.1-9.fc15.i686 は gcc-gfortran-4.6.0-10.fc15.i686 の複製です
ghostscript-9.04-3.fc15.i686 は ghostscript-9.02-1.fc15.i686 の複製です
ghostscript-cups-9.04-3.fc15.i686 は ghostscript-cups-9.02-1.fc15.i686 の複製です
git-1.7.6.4-1.fc15.i686 は git-1.7.6.2-1.fc15.i686 の複製です
gnome-python2-extras-2.25.3-35.fc15.1.i686 は gnome-python2-extras-2.25.3-34.fc15.i686 の複製です
gnupg2-2.0.18-1.fc15.i686 は gnupg2-2.0.17-1.fc15.i686 の複製です
grubby-7.0.16-5.fc15.i686 は grubby-7.0.16-4.fc15.i686 の複製です
ibus-1.4.0-2.fc15.i686 は ibus-1.3.99.20110817-4.fc15.i686 の複製です
ibus-gtk2-1.4.0-2.fc15.i686 は ibus-gtk2-1.3.99.20110817-4.fc15.i686 の複製です
ibus-gtk3-1.4.0-2.fc15.i686 は ibus-gtk3-1.3.99.20110817-4.fc15.i686 の複製です
ibus-libs-1.4.0-2.fc15.i686 は ibus-libs-1.3.99.20110817-4.fc15.i686 の複製です
kernel-headers-2.6.40.6-0.fc15.i686 は kernel-headers-2.6.40.4-5.fc15.i686 の複製です
libcollection-0.6.1-5.fc15.i686 は libcollection-0.6.0-4.fc15.i686 の複製です
libcurl-7.21.3-12.fc15.i686 は libcurl-7.21.3-11.fc15.i686 の複製です
liberation-fonts-common-1.07.1-1.fc15.noarch は liberation-fonts-common-1.07.0-1.fc15.noarch の複製です
liberation-mono-fonts-1.07.1-1.fc15.noarch は liberation-mono-fonts-1.07.0-1.fc15.noarch の複製です
liberation-sans-fonts-1.07.1-1.fc15.noarch は liberation-sans-fonts-1.07.0-1.fc15.noarch の複製です
liberation-serif-fonts-1.07.1-1.fc15.noarch は liberation-serif-fonts-1.07.0-1.fc15.noarch の複製です
libgcc-4.6.1-9.fc15.i686 は libgcc-4.6.0-10.fc15.i686 の複製です
libgfortran-4.6.1-9.fc15.i686 は libgfortran-4.6.0-10.fc15.i686 の複製です
libgomp-4.6.1-9.fc15.i686 は libgomp-4.6.0-10.fc15.i686 の複製です
libini_config-0.6.2-5.fc15.i686 は libini_config-0.6.1-4.fc15.i686 の複製です
libpanelappletmm-2.26.0-2.fc12.i686 は次の要求が不足ています:  libpanel-applet-2.so.0
libpath_utils-0.2.1-5.fc15.i686 は libpath_utils-0.2.1-4.fc15.i686 の複製です
libquadmath-4.6.1-9.fc15.i686 は libquadmath-4.6.0-10.fc15.i686 の複製です
libquadmath-devel-4.6.1-9.fc15.i686 は libquadmath-devel-4.6.0-10.fc15.i686 の複製です
libref_array-0.1.2-5.fc15.i686 は libref_array-0.1.1-4.fc15.i686 の複製です
libstdc++-4.6.1-9.fc15.i686 は libstdc++-4.6.0-10.fc15.i686 の複製です
libstdc++-devel-4.6.1-9.fc15.i686 は libstdc++-devel-4.6.0-10.fc15.i686 の複製です
libtool-2.4-6.fc15.i686 は libtool-2.4-4.fc15.i686 の複製です
pcsc-lite-libs-1.7.2-4.fc15.i686 は pcsc-lite-libs-1.7.2-3.fc15.i686 の複製です
1:perl-FCGI-0.74-1.fc15.i686 は 1:perl-FCGI-0.71-5.fc15.i686 の複製です
perl-Git-1.7.6.4-1.fc15.noarch は perl-Git-1.7.6.2-1.fc15.noarch の複製です
python-beaker-1.5.4-1.fc15.noarch は python-beaker-1.5.3-8.fc15.noarch の複製です
1:qt-4.7.4-2.fc15.i686 は 1:qt-4.7.3-8.fc15.i686 の複製です
rpm-4.9.1.2-1.fc15.i686 は rpm-4.9.1.1-1.fc15.i686 の複製です
rpm-build-4.9.1.2-1.fc15.i686 は rpm-build-4.9.1.1-1.fc15.i686 の複製です
rpm-build-libs-4.9.1.2-1.fc15.i686 は rpm-build-libs-4.9.1.1-1.fc15.i686 の複製です
rpm-libs-4.9.1.2-1.fc15.i686 は rpm-libs-4.9.1.1-1.fc15.i686 の複製です
rpm-python-4.9.1.2-1.fc15.i686 は rpm-python-4.9.1.1-1.fc15.i686 の複製です
sane-backends-1.0.22-4.fc15.i686 は次のインストール済みと衝突しています:  sane-backends < ('0', '1.0.22', '4'): sane-backends-1.0.22-3.fc15.i686
sane-backends-1.0.22-4.fc15.i686 は sane-backends-1.0.22-3.fc15.i686 の複製です
sane-backends-libs-1.0.22-4.fc15.i686 は sane-backends-libs-1.0.22-3.fc15.i686 の複製です
selinux-policy-3.9.16-39.fc15.noarch は selinux-policy-3.9.16-38.fc15.noarch の複製です
selinux-policy-targeted-3.9.16-39.fc15.noarch は selinux-policy-targeted-3.9.16-38.fc15.noarch の複製です
suitesparse-3.6.1-1.fc15.i686 は suitesparse-3.6.0-3.fc15.i686 の複製です
systemd-26-10.fc15.i686 は systemd-26-9.fc15.i686 の複製です
systemd-sysv-26-10.fc15.i686 は systemd-sysv-26-9.fc15.i686 の複製です
systemd-units-26-10.fc15.i686 は systemd-units-26-9.fc15.i686 の複製です
tigervnc-license-1.1.0-1.fc15.noarch は tigervnc-license-1.0.90-4.fc15.noarch の複製です
tzdata-2011k-0.1.20110921.fc15.noarch は tzdata-2011i-1.fc15.noarch の複製です
2:vim-common-7.3.315-1.fc15.i686 は 2:vim-common-7.3.289-1.fc15.i686 の複製です
2:vim-enhanced-7.3.315-1.fc15.i686 は 2:vim-enhanced-7.3.289-1.fc15.i686 の複製です
2:vim-filesystem-7.3.315-1.fc15.i686 は 2:vim-filesystem-7.3.289-1.fc15.i686 の複製です
vpnc-script-0.5.3-13.svn457.fc15.noarch は vpnc-script-0.5.3-12.svn457.fc15.noarch の複製です
1:xscreensaver-base-5.15-1.fc15.i686 は 1:xscreensaver-base-5.14-1.fc15.i686 の複製です
1:xscreensaver-extras-base-5.15-1.fc15.i686 は 1:xscreensaver-extras-base-5.14-1.fc15.i686 の複製です
1:xscreensaver-gl-base-5.15-1.fc15.i686 は 1:xscreensaver-gl-base-5.14-1.fc15.i686 の複製です
xulrunner-7.0.1-1.fc15.i686 は xulrunner-6.0.2-1.fc15.i686 の複製です
と、と、と、妙な日本語だけど、どうやらアップデート後に古いパッケージを消す直前に回線が落ちたようで、2つのバージョンが混在している模様。
この場合は、$ sudo package-cleanup --cleandupesを行う事で、重複したパッケージを最適化してくれるようだ。
$ LANG=C sudo package-cleanup --cleandupes
Loaded plugins: presto, refresh-packagekit
--> Running transaction check
---> Package NetworkManager.i686 1:0.9.0-1.fc15 will be erased
---> Package NetworkManager-glib.i686 1:0.9.0-1.fc15 will be erased
---> Package abrt.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-addon-ccpp.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-addon-kerneloops.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-addon-python.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-desktop.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-gui.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-libs.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-plugin-bugzilla.i686 0:2.0.3-1.fc15 will be erased
---> Package abrt-plugin-logger.i686 0:2.0.3-1.fc15 will be erased
---> Package cheese.i686 1:3.0.1-2.fc15 will be erased
---> Package cheese-libs.i686 1:3.0.1-2.fc15 will be erased
---> Package cpp.i686 0:4.6.0-10.fc15 will be erased
---> Package cups.i686 1:1.4.8-2.fc15 will be erased
---> Package cups-libs.i686 1:1.4.8-2.fc15 will be erased
---> Package curl.i686 0:7.21.3-11.fc15 will be erased
---> Package firefox.i686 0:6.0.2-1.fc15 will be erased
---> Package fuse.i686 0:2.8.5-5.fc15 will be erased
---> Package gcc.i686 0:4.6.0-10.fc15 will be erased
---> Package gcc-c++.i686 0:4.6.0-10.fc15 will be erased
---> Package gcc-gfortran.i686 0:4.6.0-10.fc15 will be erased
---> Package ghostscript.i686 0:9.02-1.fc15 will be erased
---> Package ghostscript-cups.i686 0:9.02-1.fc15 will be erased
---> Package git.i686 0:1.7.6.2-1.fc15 will be erased
---> Package gnome-python2-extras.i686 0:2.25.3-34.fc15 will be erased
--> Processing Dependency: gnome-python2-extras = 2.25.3-34.fc15 for package: gnome-python2-libegg-2.25.3-34.fc15.i686
--> Processing Dependency: gnome-python2-extras = 2.25.3-34.fc15 for package: gnome-python2-gtkhtml2-2.25.3-34.fc15.i686
---> Package gnupg2.i686 0:2.0.17-1.fc15 will be erased
---> Package grubby.i686 0:7.0.16-4.fc15 will be erased
---> Package ibus.i686 0:1.3.99.20110817-4.fc15 will be erased
---> Package ibus-gtk2.i686 0:1.3.99.20110817-4.fc15 will be erased
---> Package ibus-gtk3.i686 0:1.3.99.20110817-4.fc15 will be erased
---> Package ibus-libs.i686 0:1.3.99.20110817-4.fc15 will be erased
---> Package libcollection.i686 0:0.6.0-4.fc15 will be erased
---> Package libcurl.i686 0:7.21.3-11.fc15 will be erased
---> Package liberation-fonts-common.noarch 0:1.07.0-1.fc15 will be erased
---> Package liberation-mono-fonts.noarch 0:1.07.0-1.fc15 will be erased
---> Package liberation-sans-fonts.noarch 0:1.07.0-1.fc15 will be erased
---> Package liberation-serif-fonts.noarch 0:1.07.0-1.fc15 will be erased
---> Package libgcc.i686 0:4.6.0-10.fc15 will be erased
---> Package libgfortran.i686 0:4.6.0-10.fc15 will be erased
---> Package libgomp.i686 0:4.6.0-10.fc15 will be erased
---> Package libini_config.i686 0:0.6.1-4.fc15 will be erased
---> Package libpath_utils.i686 0:0.2.1-4.fc15 will be erased
---> Package libquadmath.i686 0:4.6.0-10.fc15 will be erased
---> Package libquadmath-devel.i686 0:4.6.0-10.fc15 will be erased
---> Package libref_array.i686 0:0.1.1-4.fc15 will be erased
---> Package libstdc++.i686 0:4.6.0-10.fc15 will be erased
---> Package libstdc++-devel.i686 0:4.6.0-10.fc15 will be erased
---> Package libtool.i686 0:2.4-4.fc15 will be erased
---> Package pcsc-lite-libs.i686 0:1.7.2-3.fc15 will be erased
--> Processing Dependency: pcsc-lite-libs = 1.7.2-3.fc15 for package: pcsc-lite-1.7.2-3.fc15.i686
---> Package perl-FCGI.i686 1:0.71-5.fc15 will be erased
---> Package perl-Git.noarch 0:1.7.6.2-1.fc15 will be erased
---> Package python-beaker.noarch 0:1.5.3-8.fc15 will be erased
---> Package qt.i686 1:4.7.3-8.fc15 will be erased
--> Processing Dependency: qt(x86-32) = 1:4.7.3-8.fc15 for package: 1:qt-x11-4.7.3-8.fc15.i686
---> Package rpm.i686 0:4.9.1.1-1.fc15 will be erased
---> Package rpm-build.i686 0:4.9.1.1-1.fc15 will be erased
---> Package rpm-build-libs.i686 0:4.9.1.1-1.fc15 will be erased
---> Package rpm-libs.i686 0:4.9.1.1-1.fc15 will be erased
---> Package rpm-python.i686 0:4.9.1.1-1.fc15 will be erased
---> Package sane-backends.i686 0:1.0.22-3.fc15 will be erased
---> Package sane-backends-libs.i686 0:1.0.22-3.fc15 will be erased
---> Package selinux-policy.noarch 0:3.9.16-38.fc15 will be erased
---> Package selinux-policy-targeted.noarch 0:3.9.16-38.fc15 will be erased
---> Package suitesparse.i686 0:3.6.0-3.fc15 will be erased
---> Package systemd.i686 0:26-9.fc15 will be erased
---> Package systemd-sysv.i686 0:26-9.fc15 will be erased
---> Package systemd-units.i686 0:26-9.fc15 will be erased
---> Package tigervnc-license.noarch 0:1.0.90-4.fc15 will be erased
---> Package tzdata.noarch 0:2011i-1.fc15 will be erased
---> Package vim-common.i686 2:7.3.289-1.fc15 will be erased
---> Package vim-enhanced.i686 2:7.3.289-1.fc15 will be erased
---> Package vim-filesystem.i686 2:7.3.289-1.fc15 will be erased
---> Package vpnc-script.noarch 0:0.5.3-12.svn457.fc15 will be erased
---> Package xscreensaver-base.i686 1:5.14-1.fc15 will be erased
--> Processing Dependency: xscreensaver-base = 1:5.14-1.fc15 for package: 1:xscreensaver-extras-5.14-1.fc15.i686
---> Package xscreensaver-extras-base.i686 1:5.14-1.fc15 will be erased
--> Processing Dependency: xscreensaver-extras-base = 1:5.14-1.fc15 for package: 1:xscreensaver-gl-extras-5.14-1.fc15.i686
---> Package xscreensaver-gl-base.i686 1:5.14-1.fc15 will be erased
---> Package xulrunner.i686 0:6.0.2-1.fc15 will be erased
--> Running transaction check
---> Package gnome-python2-gtkhtml2.i686 0:2.25.3-34.fc15 will be erased
---> Package gnome-python2-libegg.i686 0:2.25.3-34.fc15 will be erased
---> Package pcsc-lite.i686 0:1.7.2-3.fc15 will be erased
--> Processing Dependency: pcsc-lite >= 1.7.0 for package: pcsc-lite-ccid-1.4.3-1.fc15.i686
--> Processing Dependency: pcsc-lite for package: coolkey-1.1.0-19.fc15.i686
---> Package qt-x11.i686 1:4.7.3-8.fc15 will be erased
--> Processing Dependency: libQt3Support.so.4 for package: oprofile-gui-0.9.6-21.fc15.i686
--> Processing Dependency: libQtGui.so.4 for package: oprofile-gui-0.9.6-21.fc15.i686
---> Package xscreensaver-extras.i686 1:5.14-1.fc15 will be erased
---> Package xscreensaver-gl-extras.i686 1:5.14-1.fc15 will be erased
--> Running transaction check
---> Package coolkey.i686 0:1.1.0-19.fc15 will be erased
---> Package oprofile-gui.i686 0:0.9.6-21.fc15 will be erased
---> Package pcsc-lite-ccid.i686 0:1.4.3-1.fc15 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================
 Package                            Arch             Version                             Repository                                              Size
======================================================================================================================================================
Removing:
 NetworkManager                     i686             1:0.9.0-1.fc15                      @updates                                               6.0 M
 NetworkManager-glib                i686             1:0.9.0-1.fc15                      @updates                                               675 k
 abrt                               i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686           524 k
 abrt-addon-ccpp                    i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686           107 k
 abrt-addon-kerneloops              i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686            38 k
 abrt-addon-python                  i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686            14 k
 abrt-desktop                       i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686           0.0
 abrt-gui                           i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686           205 k
 abrt-libs                          i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686            21 k
 abrt-plugin-bugzilla               i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686            35 k
 abrt-plugin-logger                 i686             2.0.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686           6.9 k
 cheese                             i686             1:3.0.1-2.fc15                      @anaconda-InstallationRepo-201105131946.i686           528 k
 cheese-libs                        i686             1:3.0.1-2.fc15                      @anaconda-InstallationRepo-201105131946.i686           5.4 M
 cpp                                i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686            10 M
 cups                               i686             1:1.4.8-2.fc15                      @anaconda-InstallationRepo-201105131946.i686            11 M
 cups-libs                          i686             1:1.4.8-2.fc15                      @anaconda-InstallationRepo-201105131946.i686           703 k
 curl                               i686             7.21.3-11.fc15                      @updates                                               439 k
 firefox                            i686             6.0.2-1.fc15                        @updates                                                21 M
 fuse                               i686             2.8.5-5.fc15                        @anaconda-InstallationRepo-201105131946.i686           182 k
 gcc                                i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686            26 M
 gcc-c++                            i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686            11 M
 gcc-gfortran                       i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686            11 M
 ghostscript                        i686             9.02-1.fc15                         @anaconda-InstallationRepo-201105131946.i686            13 M
 ghostscript-cups                   i686             9.02-1.fc15                         @anaconda-InstallationRepo-201105131946.i686            50 k
 git                                i686             1.7.6.2-1.fc15                      @updates                                                12 M
 gnome-python2-extras               i686             2.25.3-34.fc15                      @updates                                               202 k
 gnupg2                             i686             2.0.17-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           5.5 M
 grubby                             i686             7.0.16-4.fc15                       @anaconda-InstallationRepo-201105131946.i686            82 k
 ibus                               i686             1.3.99.20110817-4.fc15              @updates                                               1.8 M
 ibus-gtk2                          i686             1.3.99.20110817-4.fc15              @updates                                                24 k
 ibus-gtk3                          i686             1.3.99.20110817-4.fc15              @updates                                                24 k
 ibus-libs                          i686             1.3.99.20110817-4.fc15              @updates                                               438 k
 libcollection                      i686             0.6.0-4.fc15                        @anaconda-InstallationRepo-201105131946.i686            88 k
 libcurl                            i686             7.21.3-11.fc15                      @updates                                               362 k
 liberation-fonts-common            noarch           1.07.0-1.fc15                       @anaconda-InstallationRepo-201105131946.i686            53 k
 liberation-mono-fonts              noarch           1.07.0-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           445 k
 liberation-sans-fonts              noarch           1.07.0-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           538 k
 liberation-serif-fonts             noarch           1.07.0-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           559 k
 libgcc                             i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686           137 k
 libgfortran                        i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686           1.0 M
 libgomp                            i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686           100 k
 libini_config                      i686             0.6.1-4.fc15                        @anaconda-InstallationRepo-201105131946.i686            72 k
 libpath_utils                      i686             0.2.1-4.fc15                        @anaconda-InstallationRepo-201105131946.i686            52 k
 libquadmath                        i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686           496 k
 libquadmath-devel                  i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686            16 k
 libref_array                       i686             0.1.1-4.fc15                        @anaconda-InstallationRepo-201105131946.i686            48 k
 libstdc++                          i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686           980 k
 libstdc++-devel                    i686             4.6.0-10.fc15                       @anaconda-InstallationRepo-201105131946.i686           7.2 M
 libtool                            i686             2.4-4.fc15                          @anaconda-InstallationRepo-201105131946.i686           2.2 M
 pcsc-lite-libs                     i686             1.7.2-3.fc15                        @anaconda-InstallationRepo-201105131946.i686            40 k
 perl-FCGI                          i686             1:0.71-5.fc15                       @anaconda-InstallationRepo-201105131946.i686            86 k
 perl-Git                           noarch           1.7.6.2-1.fc15                      @updates                                                44 k
 python-beaker                      noarch           1.5.3-8.fc15                        @anaconda-InstallationRepo-201105131946.i686           280 k
 qt                                 i686             1:4.7.3-8.fc15                      @anaconda-InstallationRepo-201105131946.i686            15 M
 rpm                                i686             4.9.1.1-1.fc15                      @anaconda-InstallationRepo-201105131946.i686           1.9 M
 rpm-build                          i686             4.9.1.1-1.fc15                      @anaconda-InstallationRepo-201105131946.i686           290 k
 rpm-build-libs                     i686             4.9.1.1-1.fc15                      @anaconda-InstallationRepo-201105131946.i686           158 k
 rpm-libs                           i686             4.9.1.1-1.fc15                      @anaconda-InstallationRepo-201105131946.i686           540 k
 rpm-python                         i686             4.9.1.1-1.fc15                      @anaconda-InstallationRepo-201105131946.i686           110 k
 sane-backends                      i686             1.0.22-3.fc15                       @anaconda-InstallationRepo-201105131946.i686           4.5 M
 sane-backends-libs                 i686             1.0.22-3.fc15                       @anaconda-InstallationRepo-201105131946.i686           7.9 M
 selinux-policy                     noarch           3.9.16-38.fc15                      @updates                                               8.1 M
 selinux-policy-targeted            noarch           3.9.16-38.fc15                      @updates                                               3.6 M
 suitesparse                        i686             3.6.0-3.fc15                        @anaconda-InstallationRepo-201105131946.i686           2.1 M
 systemd                            i686             26-9.fc15                           @updates                                               2.1 M
 systemd-sysv                       i686             26-9.fc15                           @updates                                               3.9 k
 systemd-units                      i686             26-9.fc15                           @updates                                               286 k
 tigervnc-license                   noarch           1.0.90-4.fc15                       @anaconda-InstallationRepo-201105131946.i686            18 k
 tzdata                             noarch           2011i-1.fc15                        @updates                                               1.7 M
 vim-common                         i686             2:7.3.289-1.fc15                    @updates                                                18 M
 vim-enhanced                       i686             2:7.3.289-1.fc15                    @updates                                               1.9 M
 vim-filesystem                     i686             2:7.3.289-1.fc15                    @updates                                               0.0
 vpnc-script                        noarch           0.5.3-12.svn457.fc15                @anaconda-InstallationRepo-201105131946.i686            18 k
 xscreensaver-base                  i686             1:5.14-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           1.3 M
 xscreensaver-extras-base           i686             1:5.14-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           169 k
 xscreensaver-gl-base               i686             1:5.14-1.fc15                       @anaconda-InstallationRepo-201105131946.i686            20 k
 xulrunner                          i686             6.0.2-1.fc15                        @updates                                                25 M
Removing for dependencies:
 coolkey                            i686             1.1.0-19.fc15                       @anaconda-InstallationRepo-201105131946.i686           207 k
 gnome-python2-gtkhtml2             i686             2.25.3-34.fc15                      @updates                                                21 k
 gnome-python2-libegg               i686             2.25.3-34.fc15                      @updates                                                30 k
 oprofile-gui                       i686             0.9.6-21.fc15                       @anaconda-InstallationRepo-201105131946.i686           187 k
 pcsc-lite                          i686             1.7.2-3.fc15                        @anaconda-InstallationRepo-201105131946.i686           530 k
 pcsc-lite-ccid                     i686             1.4.3-1.fc15                        @anaconda-InstallationRepo-201105131946.i686           477 k
 qt-x11                             i686             1:4.7.3-8.fc15                      @anaconda-InstallationRepo-201105131946.i686            32 M
 xscreensaver-extras                i686             1:5.14-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           6.3 M
 xscreensaver-gl-extras             i686             1:5.14-1.fc15                       @anaconda-InstallationRepo-201105131946.i686           9.2 M

Transaction Summary
======================================================================================================================================================
Remove       86 Package(s)

Installed size: 296 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
** Found 2 pre-existing rpmdb problem(s), 'yum check' outpng    : abrt-addon-kerneloops-2.0.3-1.fc15.i686                                                                                           7/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : rpm-build-4.9.1.1-1.fc15.i686                                                                                                     8/86
  Erasing    : gcc-gfortran-4.6.0-10.fc15.i686                                                                                                   9/86
  Erasing    : rpm-build-libs-4.9.1.1-1.fc15.i686                                                                                               10/86
  Erasing    : abrt-plugin-bugzilla-2.0.3-1.fc15.i686                                                                                           11/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : 1:cups-1.4.8-2.fc15.i686                                                                                                         12/86
  Erasing    : ghostscript-cups-9.02-1.fc15.i686                                                                                                13/86
  Erasing    : libini_config-0.6.1-4.fc15.i686                                                                                                  14/86
  Erasing    : gcc-c++-4.6.0-10.fc15.i686                                                                                                       15/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : ghostscript-9.02-1.fc15.i686                                                                                                     16/86
  Erasing    : 1:cups-libs-1.4.8-2.fc15.i686                                                                                                    17/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : libgfortran-4.6.0-10.fc15.i686                                                                                                   18/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : libquadmath-devel-4.6.0-10.fc15.i686                                                                                             19/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : 1:qt-4.7.3-8.fc15.i686                                                                                                           20/86
  Erasing    : xulrunner-6.0.2-1.fc15.i686                                                                                                      21/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : abrt-addon-ccpp-2.0.3-1.fc15.i686                                                                                                22/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : ibus-gtk3-1.3.99.20110817-4.fc15.i686                                                                                            23/86
  Erasing    : ibus-1.3.99.20110817-4.fc15.i686                                                                                                 24/86
  Erasing    : ibus-gtk2-1.3.99.20110817-4.fc15.i686                                                                                            25/86
  Erasing    : 1:xscreensaver-gl-extras-5.14-1.fc15.i686                                                                                        26/86
  Erasing    : suitesparse-3.6.0-3.fc15.i686                                                                                                    27/86
  Erasing    : 1:NetworkManager-0.9.0-1.fc15.i686                                                                                               28/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : 1:xscreensaver-extras-5.14-1.fc15.i686                                                                   Erasing    : gnome-python2-libegg-2.25.3-34.fc15.i686                                                                                         51/86
  Erasing    : liberation-sans-fonts-1.07.0-1.fc15.noarch                                                                                       52/86
  Erasing    : 1:cheese-3.0.1-2.fc15.i686                                                                                                       53/86
  Erasing    : systemd-sysv-26-9.fc15.i686                                                                                                      54/86
  Erasing    : systemd-26-9.fc15.i686                                                                                                           55/86
  Erasing    : liberation-mono-fonts-1.07.0-1.fc15.noarch                                                                                       56/86
  Erasing    : liberation-serif-fonts-1.07.0-1.fc15.noarch                                                                                      57/86
  Erasing    : selinux-policy-targeted-3.9.16-38.fc15.noarch                                                                                    58/86
  Erasing    : gnome-python2-gtkhtml2-2.25.3-34.fc15.i686                                                                                       59/86
  Erasing    : libtool-2.4-4.fc15.i686                                                                                                          60/86
  Erasing    : gcc-4.6.0-10.fc15.i686                                                                                                           61/86
  Erasing    : libgomp-4.6.0-10.fc15.i686                                                                                                       62/86
  Erasing    : libgcc-4.6.0-10.fc15.i686                                                                                                        63/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : cpp-4.6.0-10.fc15.i686                                                                                                           64/86
  Erasing    : gnome-python2-extras-2.25.3-34.fc15.i686                                                                                         65/86
  Erasing    : selinux-policy-3.9.16-38.fc15.noarch                                                                                             66/86
  Erasing    : liberation-fonts-common-1.07.0-1.fc15.noarch                                                                                     67/86
  Erasing    : systemd-units-26-9.fc15.i686                                                                                                     68/86
  Erasing    : 1:cheese-libs-3.0.1-2.fc15.i686                                                                                                  69/86
  Erasing    : 2:vim-filesystem-7.3.289-1.fc15.i686                                                                                             70/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : libcurl-7.21.3-11.fc15.i686                                                                                                      71/86
  Erasing    : pcsc-lite-libs-1.7.2-3.fc15.i686                                                                                                 72/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : 1:xscreensaver-base-5.14-1.fc15.i686                                                                                             73/86
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Erasing    : 1:NetworkManager-glib-0.9.0-1.fc15.i686                                                                                          74/86
  Erasing    : ibus-libs-1.3.99.20110817-4.fc15.i686                                                                                gcc-c++.i686 0:4.6.0-10.fc15
  gcc-gfortran.i686 0:4.6.0-10.fc15               ghostscript.i686 0:9.02-1.fc15                    ghostscript-cups.i686 0:9.02-1.fc15
  git.i686 0:1.7.6.2-1.fc15                       gnome-python2-extras.i686 0:2.25.3-34.fc15        gnupg2.i686 0:2.0.17-1.fc15
  grubby.i686 0:7.0.16-4.fc15                     ibus.i686 0:1.3.99.20110817-4.fc15                ibus-gtk2.i686 0:1.3.99.20110817-4.fc15
  ibus-gtk3.i686 0:1.3.99.20110817-4.fc15         ibus-libs.i686 0:1.3.99.20110817-4.fc15           libcollection.i686 0:0.6.0-4.fc15
  libcurl.i686 0:7.21.3-11.fc15                   liberation-fonts-common.noarch 0:1.07.0-1.fc15    liberation-mono-fonts.noarch 0:1.07.0-1.fc15
  liberation-sans-fonts.noarch 0:1.07.0-1.fc15    liberation-serif-fonts.noarch 0:1.07.0-1.fc15     libgcc.i686 0:4.6.0-10.fc15
  libgfortran.i686 0:4.6.0-10.fc15                libgomp.i686 0:4.6.0-10.fc15                      libini_config.i686 0:0.6.1-4.fc15
  libpath_utils.i686 0:0.2.1-4.fc15               libquadmath.i686 0:4.6.0-10.fc15                  libquadmath-devel.i686 0:4.6.0-10.fc15
  libref_array.i686 0:0.1.1-4.fc15                libstdc++.i686 0:4.6.0-10.fc15                    libstdc++-devel.i686 0:4.6.0-10.fc15
  libtool.i686 0:2.4-4.fc15                       pcsc-lite-libs.i686 0:1.7.2-3.fc15                perl-FCGI.i686 1:0.71-5.fc15
  perl-Git.noarch 0:1.7.6.2-1.fc15                python-beaker.noarch 0:1.5.3-8.fc15               qt.i686 1:4.7.3-8.fc15
  rpm.i686 0:4.9.1.1-1.fc15                       rpm-build.i686 0:4.9.1.1-1.fc15                   rpm-build-libs.i686 0:4.9.1.1-1.fc15
  rpm-libs.i686 0:4.9.1.1-1.fc15                  rpm-python.i686 0:4.9.1.1-1.fc15                  sane-backends.i686 0:1.0.22-3.fc15
  sane-backends-libs.i686 0:1.0.22-3.fc15         selinux-policy.noarch 0:3.9.16-38.fc15            selinux-policy-targeted.noarch 0:3.9.16-38.fc15
  suitesparse.i686 0:3.6.0-3.fc15                 systemd.i686 0:26-9.fc15                          systemd-sysv.i686 0:26-9.fc15
  systemd-units.i686 0:26-9.fc15                  tigervnc-license.noarch 0:1.0.90-4.fc15           tzdata.noarch 0:2011i-1.fc15
  vim-common.i686 2:7.3.289-1.fc15                vim-enhanced.i686 2:7.3.289-1.fc15                vim-filesystem.i686 2:7.3.289-1.fc15
  vpnc-script.noarch 0:0.5.3-12.svn457.fc15       xscreensaver-base.i686 1:5.14-1.fc15              xscreensaver-extras-base.i686 1:5.14-1.fc15
  xscreensaver-gl-base.i686 1:5.14-1.fc15         xulrunner.i686 0:6.0.2-1.fc15

Dependency Removed:
  coolkey.i686 0:1.1.0-19.fc15               gnome-python2-gtkhtml2.i686 0:2.25.3-34.fc15          gnome-python2-libegg.i686 0:2.25.3-34.fc15
  oprofile-gui.i686 0:0.9.6-21.fc15          pcsc-lite.i686 0:1.7.2-3.fc15                         pcsc-lite-ccid.i686 0:1.4.3-1.fc15
  qt-x11.i686 1:4.7.3-8.fc15                 xscreensaver-extras.i686 1:5.14-1.fc15                xscreensaver-gl-extras.i686 1:5.14-1.fc15

Complete!
そして、改めてupdateしてみると…
$ LANG=C sudo yum update
yum update
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package exiv2-libs.i686 0:0.21.1-1.fc15 will be updated
---> Package exiv2-libs.i686 0:0.21.1-3.fc15 will be an update
---> Package fftw.i686 0:3.2.2-5.fc15 will be obsoleted
---> Package fftw-libs.i686 0:3.3-2.fc15 will be obsoleting
---> Package fuse-libs.i686 0:2.8.5-5.fc15 will be updated
---> Package fuse-libs.i686 0:2.8.6-1.fc15 will be an update
---> Package gnome-screensaver.i686 0:3.0.0-1.fc15 will be updated
---> Package gnome-screensaver.i686 0:3.0.1-1.fc15 will be an update
---> Package iw.i686 0:0.9.22-1.fc15 will be updated
---> Package iw.i686 0:3.1-1.fc15 will be an update
---> Package libburn.i686 0:1.1.0-1.fc15 will be updated
---> Package libburn.i686 0:1.1.4-1.fc15 will be an update
---> Package libdhash.i686 0:0.4.2-4.fc15 will be updated
---> Package libdhash.i686 0:0.4.3-5.fc15 will be an update
---> Package libgcj.i686 0:4.6.0-10.fc15 will be updated
---> Package libgcj.i686 0:4.6.1-9.fc15 will b              updates                        23 k
 libgcj                                  i686                       4.6.1-9.fc15                                  updates                        17 M
 libisofs                                i686                       1.1.4-1.fc15                                  updates                       351 k
 libtool-ltdl                            i686                       2.4-6.fc15                                    updates                        45 k
 lzo                                     i686                       2.06-1.fc15                                   updates                        61 k
 nfs-utils                               i686                       1:1.2.4-3.fc15                                updates                       307 k
 perf                                    i686                       2.6.40.6-0.fc15                               updates                       371 k
 postgresql-libs                         i686                       9.0.5-1.fc15                                  updates                       211 k
 protobuf                                i686                       2.3.0-8.fc15                                  updates                       297 k
 rdesktop                                i686                       1.7.0-1.fc15                                  updates                       153 k
 tar                                     i686                       2:1.26-2.fc15                                 updates                       824 k
 tigervnc                                i686                       1.1.0-1.fc15                                  updates                       185 k
 usbutils                                i686                       003-4.fc15                                    updates                        70 k
 vim-minimal                             i686                       2:7.3.315-1.fc15                              updates                       348 k
 vpnc                                    i686                       0.5.3-13.svn457.fc15                          updates                        79 k

Transaction Summary
======================================================================================================================================================
Install       1 Package(s)
Upgrade      20 Package(s)

Total download size: 24 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
updates/prestodelta                                                                                                            | 710 kB     00:01
Processing delta metadata
Download delta size: 4.3 M
(1/18): exiv2-libs-0.21.1-1.fc15_0.21.1-3.fc15.i686.drpm                                                                       | 268 kB     00:00
(2/18): fuse-libs-2.8.5-5.fc15_2.8.6-1.fc15.i686.drpm                                                                          |  23 kB     00:00
(3/18): gnome-screensaver-3.0.0-1.fc15_3.0.1-1.fc15.i686.drpm                                                                  | 108 kB     00:00
(4/18): libburn-1.1.0-1.fc15_1.1.4-1.fc15.i686.drpm                                                                            |  25 kB     00:00
(5/18): libdhash-0.4.2-4.fc15_0.4.3-5.fc15.i686.drpm                                                                           | 7.1 kB     00:00
(6/18): libgcj-4.6.0-10.fc15_4.6.1-9.fc15.i686.drpm                                                                            | 2.0 MB     00:04
(7/18): libisofs-1.1.2-1.fc15_1.1.4-1.fc15.i686.drpm                                                                           | 262 kB     00:00
(8/18): libtool-ltdl-2.4-4.fc15_2.4-6.fc15.i686.drpm                                                                           |  26 kB     00:00
(9/18): lzo-2.03-4.fc15_2.06-1.fc15.i686.drpm                                                                                  |  40 kB     00:00
(10/18): nfs-utils-1.2.4-2.fc15_1.2.4-3.fc15.i686.drpm                                       sofs-1.1.4-1.fc15.i686                                                                                                        5/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : libgcj-4.6.1-9.fc15.i686                                                                                                          6/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : lzo-2.06-1.fc15.i686                                                                                                              7/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : tigervnc-1.1.0-1.fc15.i686                                                                                                        8/42
  Updating   : protobuf-2.3.0-8.fc15.i686                                                                                                        9/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Installing : fftw-libs-3.3-2.fc15.i686                                                                                                        10/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : usbutils-003-4.fc15.i686                                                                                                         11/42
  Updating   : exiv2-libs-0.21.1-3.fc15.i686                                                                                                    12/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : 2:tar-1.26-2.fc15.i686                                                                                                           13/42
  Updating   : postgresql-libs-9.0.5-1.fc15.i686                                                                                                14/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : 1:nfs-utils-1.2.4-3.fc15.i686                                                                                                    15/42
  Updating   : vpnc-0.5.3-13.svn457.fc15.i686                                                                                                   16/42
  Updating   : perf-2.6.40.6-0.fc15.i686                                                                                                        17/42
  Updating   : libdhash-0.4.3-5.fc15.i686                                                                                                       18/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Updating   : 2:vim-minimal-7.3.315-1.fc15.i686                                                                                                19/42
  Updating   : iw-3.1-1.fc15.i686                                                                                                               20/42
  Updating   : fuse-libs-2.8.6-1.fc15.i686                                                                                                      21/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Cleanup    : libburn-1.1.0-1.fc15.i686                                                                                                        22/42
  Cleanup    : rdesktop-1.6.0-12.fc15.i686                                                                                                      23/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated

  Cleanup    : gnome-screensaver-3.0.0-1.fc15.i686                                                                                              24/42
  Cleanup    : libtool-ltdl-2.4-4.fc15.i686                                                                                                     25/42
  Cleanup    : libisofs-1.1.2-1.fc15.i686                                                                                                       26/42
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e  nfs-utils.i686 1:1.2.4-3.fc15            perf.i686 0:2.6.40.6-0.fc15
  postgresql-libs.i686 0:9.0.5-1.fc15    protobuf.i686 0:2.3.0-8.fc15     rdesktop.i686 0:1.7.0-1.fc15             tar.i686 2:1.26-2.fc15
  tigervnc.i686 0:1.1.0-1.fc15           usbutils.i686 0:003-4.fc15       vim-minimal.i686 2:7.3.315-1.fc15        vpnc.i686 0:0.5.3-13.svn457.fc15

Replaced:
  fftw.i686 0:3.2.2-5.fc15

Complete!
やれやれ……

他に

yumでトラブったときはこのようなコマンドも覚えておくと良い
yum clean all
まずはキャッシュのクリア。落ちてくるはずのアップデートが何故か落ちてこない等の時に。
yum-complete-transaction
yumの途中で強制終了した/させてしまった場合など、トランザクションを途中から再開するためのコマンド。多くの場合、yum updateなどを再度行おうとすると、このコマンドを叩けと指示される。
rpm --rebuilddb
rpmのデータベースの修復コマンド。"データベースが異常"などと出ていた場合には、これでデータベースを再構築すると復活する。

ldconfig: file XXXX is truncated問題 2011/10/14

上記のログに出ていた
/sbin/ldconfig: file /usr/lib/libQt3Support.so.4.7.4;4e9466a4 is truncated
については、lsしてみると、
$  ls /usr/lib/libQt3* -l

-rw-r--r-- 1 root root 1900544 10月 12 02:28 /usr/lib/libQt3Support.so.4.7.4;4e9466a4
となっていて、これを提供するパッケージを調べてみると
$ yum whatprovides */libQt3Support.so.4.7.4


読み込んだプラグイン:fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: ftp.iij.ad.jp
 * updates: ftp.iij.ad.jp
fedora/filelists_db                                                                                                                                                                     |  18 MB     00:10
updates/filelists_db                                                                                                                                                                    | 7.0 MB     00:04
1:qt-x11-4.7.4-2.fc15.i686 : Qt GUI-related libraries
リポジトリー        : updates
一致          :
ファイル名    : /usr/lib/libQt3Support.so.4.7.4



1:qt-x11-4.7.4-2.fc15.i686 : Qt GUI-related libraries
リポジトリー        : installed
一致          :
ファイル名    : /usr/lib/libQt3Support.so.4.7.4

$  yum info qt-x11


読み込んだプラグイン:presto, refresh-packagekit
利用可能なパッケージ
名前                : qt-x11
アーキテクチャ      : i686
エポック            : 1
バージョン          : 4.7.4
リリース            : 2.fc15
容量                : 12 M
リポジトリー        : updates
要約                : Qt GUI-related libraries
URL                 : http://www.qtsoftware.com/
ライセンス          : (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
説明                : Qt libraries used for drawing widgets and OpenGL items.
という具合にインストールされてなかったので、単純にrmしてldconfigし直して終了。
$  sudo rm -f /usr/lib/libQt3Support.so.4.7.4;4e9466a4

$  sudo ldconfig
OK キャンセル 確認 その他