2008/05/27(Tue)JavaApplet Trouble

2008/05/27 15:09 Languages::Java
Javaアプレットを書いていたのだけど、その検証作業でいろいろトラブったのでメモ。

「異なるバージョンのJavaが必要です。異なるバージョンのセッションを再ロードしますか?」

インストールされているJREが古いと出るようだ。Version 6 Update 6にしたら直った。
(正確なメッセージは忘れた)

IEでは動くアプレットが、Sleipnirでは灰色の塗りつぶしにしか表示されない

Sun Javaをインストールしても、SleipnirがMicrosoftのプラグインを使うことが原因らしい。
regsvr32 /u msjava.dllと実行してDLLレジストを解除してから、ブラウザを再起動すればよい。
これでも動かない場合は、インターネットオプションの詳細設定の中で、「<applet> に Java 2 v1.x.x_xx を使用(再起動が必要)」にチェックがついているかどうかチェック。

FreeBSDのappletviewerが文字化けする

メニューとステータスバーが豆腐になっていた。
appletviewerを起動するとき、-encoding EUC-JPをくっつけて起動すればよい。
OK キャンセル 確認 その他